Multiple Feature Issues

Incident Report for Cash App Staging

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 18:34 UTC

Investigating

We're investigating reports of connection issues impacting multiple Cash App features, and are working to resolve this quickly. Please check out status.cash.app for real-time updates, and thanks for your patience.
Posted Apr 02, 2026 - 18:23 UTC
This incident affected: Send & Receive Money, Add Cash, Settings, and In-App Alert.